PageFour home

"We write to taste life twice."

PageFour Help - Customization

The PageFour interface has been designed to be as easy to use as possible. Everything has been placed in the position we feel it belongs and works in the way we feel is best. However, we are all unique and we all have our own opinions, both functional and aesthetic. With this in mind, we have made it possible for you to customise both the interface and the background processes in a way that suits you and the way you work.

In this Section

Customizing from the Menus

It is possible to make changes to the appearance of PageFour from many of the menus. The View menu has a number of options to change the look of the interface.

Customise from the View Menu

A series of checks beside each menu item, determine whether or not the particular item is visible.

Main Toolbar: Switches the primary toolbar on and off.

Format Toolbar: Switches the word processing toolbar on and off.

Status Bar: Switches the status bar on and off.

Notebooks List: Switches the Notebooks list on or off. If most of your work is being done in one notebook, you may not always need to see the list of other notebooks. The Jump command from the current notebook will automatically make the notebooks list visible if you have switched it off.

Current Notebook: Switches the current notebook list on or off.

Notebooks: Opens the left pane to show the notebooks list and the current notebook.

Snapshots: Switches the Snapshots list on. The notebooks and snapshots lists cannot both be visible at the same time, as they occupy the same part of the screen. The shortcut keys F9 and F10 allow you to jump between the two. F11 will switch them both off completely, thereby freeing up most of the screen for the word processor.

Full Screen Page: Switches off the left pane, allowing the word processor to occupy the full screen width.

All Off / On: Quick method of forcing the word processor to fill the screen. All off hides the toolbar, status bar, and notebooks list. All on reverses this.

Customise: Opens the Options Dialog at the toolbar section.

Most of these options have the effect of freeing up more space for the word processor. On PCs with small screens or lap tops, it is a good idea to hide some of the less often used parts of the interface.

Customise from the Toolbar Menu

The right click menu on the primary toolbar offers similar Toolbar related options:

Toolbar: Switches the primary toolbar on and off.

Large Icons: Toggles between displaying large or small icons on the toolbar.

Show Text: Switches the text on the toolbar buttons on or off. It should only be switched on for monitors with reasonably high screen resolution as it does increase the size of the toolbar.

Customise: Opens the Options Dialog at the toolbar section.

Customise from the Tabbed Word Processor

Similarly, the right click menu for the tabbed pages and the word processing toolbar has a selection of customising options:

Tabbed Pages: Switches tabbed pages on and off.

Format Toolbar: Switches the word processing toolbar on and off.

The Options Dialog

The PageFour Options Dialog can be accessed by selecting Options on the Tools menu. This dialog allows you to change both the visual appearance of parts of the interface, and affect the way some of the functionality works. The dialog is broken into five distinct sections.

Before examining these sections in detail, the button on the bottom left of the dialog should be noted. Restore Defaults allows you to restore all PageFour settings to the state they were in when it was first launched. This means that all screen positions, archive and snapshot settings, and Toolbar options will be reset.

The position of all pages and folders within notebooks will also be restored to a basic alphabetical setting. This is an important feature and should be used if the visual appearance of the notebook appears to be out of synch with the pages and folders you created.

This option should be a the starting point should any problems arise in using PageFour.

At no time will use of this option modify or delete data. You must press the OK button after selecting this option to activate the new settings.

Archiving

The auto archiving feature is switched on by default and will be pre-set to run every three days after you install PageFour. This means that every three days, an automatic archive or backup will be made of your all your notebooks. Using the Archive Manager, it is possible to view or roll back to folders or pages in these archives.

Archiving Options

You can switch auto archiving off if you wish, but this is not recommended. Most PCs these days have an abundance of free memory, and PageFour backups will impact little on this.

You can easily change the frequency with which auto archives are taken, by moving the slider from one to one hundred days. We recommend you allow auto archives at least every ten days.

The default number of archives stored at any one time is thirty, but again, you can change this to anything from one to one hundred. We recommend at least thirty archives, which would give you a full history of your Notebook for ninety days if you archive every three days. Increasing the number of archives to one hundred would allow archives to be held for almost a year.

If you decide you have no further use for your archives, you can clear them all by selecting the clear button. This action cannot be undone so should not be taken lightly. Selected archives can be deleted by opening the Archive Manager and specifying archives to delete.

Advanced Archiving Options

Selecting the Advanced button will open a new dialog which allows you to 'switch off' specified notebooks when it comes to auto-archiving.

Over time, you will probably find yourself using a large number of notebooks and pages. In all likelihood, not all of these notebooks will be used on a daily or weekly basis, so you may decide not to auto-archive these particular notebooks. It is simply a case of unchecking the notebooks in question, thereby speeding up the auto archiving process.

Remember, the Make Full Archive option on the Tools menu will always archive EVERY notebook.


Snapshots

Snapshots are stored by default for only seven days. Should you wish to increase the time they are held, simply move the snapshots slider. Snapshots can be stored for up to twenty days.

Snapshot Options

A clear all snapshots button allows you to flush all your current snapshots. This action cannot be undone so should not be taken lightly. Individual snapshots can be deleted from the snapshots list in the main window.


Toolbar

A number of changes can be made to the primary toolbar from the toolbar section of the Options Dialog.

Toolbar Options

Icon Options allows you to choose between displaying large or small icons on the toolbar.

Text Options allows you to decide whether to display text alongside the icons on the toolbar. This will increase the size of the buttons considerably.

Buttons: The list of buttons currently displayed on the toolbar is shown on the right hand side of the dialog in the Current Buttons list. Current buttons can easily be removed by moving them across to the Available Buttons list or new ones added by moving available buttons across from the other list. The position of the buttons on the toolbar can also be changed by using the up and down arrows.

If the auto save feature is enabled, you may decide to remove the Save button as it is no longer needed. The Ctrl+S shortcut keys will still initiate a save regardless of whether the button is there or not.


Privacy

The privacy settings surrounding the way Password Protection works can be altered slightly to suit the nature of the work you are doing. By default, no password is set, and new pages are not encrypted or protected in any way. Once a password has been set for your notebooks, you get to decide which pages are protected.

Privacy Options

The 'How do you wish to use your password?' question allows you to insist that all new pages are protected by your password automatically. This is a decision you can only make yourself, but we feel that this level of security is not necessary for most people. As long as you protect the libellous opinions about your boss and husband, and thereby secure your job and marriage, you may feel that the rest of your pages are fine as they are.

Should the unthinkable happen and you forget your password, you can remove the password and roll back to the original state of no password. To do this, you must first remove the pages currently locked by the forgotten password, then click on the Remove Password button.

In such a situation - may it never happen - it might be advisable to create an archive of all your notebooks first so that should you remember the password in a few weeks, you can recover these pages from the archive. To create an archive, use the Make Full Archive option on the tools menu.


Word Processor

Their are a number of cosmetic settings relating to the word processor that are also customisable.

Word Processor Options

The Page Margins (left and right) can be easily changed from the default of 20 pixels. This is especially useful if you are working with a wide screen, where the page may look unusually wide with standard margin settings.

The Background Colour is originally set to plain white. Some people find changing this colour easier on the eye. Clicking on the Colour button allows you to select any colour and make it the standard for all pages. This does not impact on printing or saving to external files, as the background colour is purely an internal PageFour setting.

The Apply background color to side windows option allows you to also change the color of the Notebooks list, current Notebook, and Smart-Edit windows, so that they correspond to the color of the word processor.

Autosave is a key feature of PageFour. There is no reason to switch it off and every reason to leave it on. The default setting is for your work to be saved every two minutes, but again you can change this if you wish. There really is no need to change this settings as you never notice when a save is occurring anyway.

Launch web browser when URLs clicked. By default, PageFour recognises web address and highlights them in blue. Clicking on these links automatically opens the selected page in your web browser. To switch this feature off, and treat web addresses as plain, ordinary text, uncheck this box.

Use smart quotes (curly quotes). Introduced in version 1.60, smart quotes can now be used in place of the more ordinary quotes. This option will be off by default, as the number of people who prefer smart quotes is fairly evenly matched by those who cannot abide them.

PageFour does not yet handle en and em dashes, but a mechanism has been put in place as a 'work around.' This is a temporary solution, and only applies when saving files as RTF out of PageFour. Anyone interested should contact me for further details.

Miscellaneous

There are a small number of miscellaneous options that can also be changed, the most important of which is changing the Location of Notebook Pages. When you open PageFour for the first time, your notebooks are set up for you in your own Application Data folder. This is the best place to store the pages as these folders are assigned to you and you alone by Windows. If another user logs on to your machine under any name but yours and opens PageFour they will not see your Notebooks.

Miscellaneous Options

If you decide for whatever reason to change the location of these pages - maybe you have a "My Backup" folder that you backup to CD every week - you must ensure that the location you specify will always be available. Do not specify a Network drive or a folder that you do not have full access rights to, otherwise PageFour will not work correctly. You should only ever change the Notebook location if you have a good reason to do so and you understand the different access levels that may exist on your PC.

If you are installing PageFour on your work PC, do not listen to your IT guys if they tell you that the location should really be changed to a drive that is backed up every night! They only pretend to know more than you because you have a far more active social life than they do.

Auto save is a key feature of PageFour. There is no reason to switch it off and every reason to leave it on. The default setting is for your work to be saved every two minutes, but again you can change this if you wish. There really is no need to change this settings as you never notice when a save is occurring anyway.

The Show Tabbed Pages settings allow you to decide whether the tabs appear on the bottom or the top of the word processor, or not at all. We believe they are more suited to the bottom where they are a little out of the way and not so in your face as you work, but feel free to change this setting if you wish.

Move Deleted Pages to the Recycle Bin. In many windows applications, deleted files are not completely deleted. They are moved to the Windows recycle bin from where they can be recovered at some future point should the need arise. PageFour gives you the option of treating any pages you delete in the same way. The downside of using the Windows recycle bin is that it can slow down the speed with which pages are deleted. By default, PageFour is optimised for speed, and the recycle bin is not used, but you can override this by specifying this option.

The Date Format can be changed to any one of a variety of date format types. This option only comes into play when you use the Insert Date menu, or its corresponding shortcut (Ctrl+D), in the word processor, or in the New Page dialog. The date inserted into your text will always fit the format selected in this drop down.

The order in which your pages and folders are displayed in the notebook is fully customisable using drag and drop. However, should you wish to undo all these settings and restore your notebooks to alphabetical lists of pages and folders, you can do so by using the Refresh Notebooks option.